Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code

Unified Diff: compiled/base.h

Issue 29613616: Issue 6064 - Put C++ code into a configurable namespace (Closed) Base URL: https://github.com/adblockplus/adblockpluscore.git
Patch Set: Fix debug.h to be aligned with assert2 (define vs function) and get rid of a warning in generator.cpp Created Nov. 21, 2017, 2:53 p.m.
Use n/p to move between diff chunks; N/P to move between comments.
Jump to:
View side-by-side diff with in-line comments
Download patch
Index: compiled/base.h
diff --git a/compiled/bindings/runtime.h b/compiled/base.h
similarity index 68%
copy from compiled/bindings/runtime.h
copy to compiled/base.h
index 549eeef479e5ace136c078f942008c21b98f1734..10a9f0022862e579446f50f15e3ff3868c5f0077 100644
--- a/compiled/bindings/runtime.h
+++ b/compiled/base.h
@@ -12,14 +12,16 @@
* GNU General Public License for more details.
*
* You should have received a copy of the GNU General Public License
- * along with Adblock Plus. If not, see <http://www.gnu.org/licenses/>.
+ * along with Adblock Plus. If not, see <http://www.gnu.org/licenses/>.
*/
#pragma once
-#if defined(__EMSCRIPTEN__)
-#include <emscripten.h>
-#define BINDINGS_EXPORTED EMSCRIPTEN_KEEPALIVE
-#else
-#define BINDINGS_EXPORTED
+// if a user config is not specified then use the default location.
+#if !defined(ABP_USER_CONFIG)
+# define ABP_USER_CONFIG "user.h"
hub 2017/11/21 16:48:39 I would call this "user-config.h". and the present
sergei 2017/11/22 09:39:26 I like to have config.h with a more specific part
+#endif
+// it should be the first included file
+#ifdef ABP_USER_CONFIG
+#include ABP_USER_CONFIG
#endif

Powered by Google App Engine
This is Rietveld