Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code | Sign in
(27)

Issue 5728072976302080: Issue 151 - [Typed objects] Implement dynamically-sized array types (Closed)

Can't Edit
Can't Publish+Mail
Start Review
Created:
5 years, 4 months ago by Wladimir Palant
Modified:
5 years, 2 months ago
CC:
tschuster
Visibility:
Public.

Description

Issue 151 - [Typed objects] Implement dynamically-sized array types

Patch Set 1 #

Total comments: 2

Patch Set 2 : Use Uint8Array as constructor, not a function #

Patch Set 3 : #

Unified diffs Side-by-side diffs Delta from patch set Stats (+787 lines, -68 lines) Patch
M lib/typedObjects.js View 2 chunks +46 lines, -0 lines 0 comments Download
A lib/typedObjects/arrayTypes.js View 1 2 1 chunk +267 lines, -0 lines 0 comments Download
M lib/typedObjects/objectTypes.js View 1 2 5 chunks +31 lines, -58 lines 0 comments Download
M lib/typedObjects/primitiveTypes.js View 1 2 1 chunk +14 lines, -4 lines 0 comments Download
M lib/typedObjects/utils.js View 1 2 2 chunks +146 lines, -6 lines 0 comments Download
M test/index.html View 1 chunk +1 line, -0 lines 0 comments Download
M test/tests/typedObjects.js View 1 1 chunk +282 lines, -0 lines 0 comments Download

Messages

Total messages: 8
Wladimir Palant
5 years, 4 months ago (2014-05-16 12:44:59 UTC) #1
Wladimir Palant
http://codereview.adblockplus.org/5728072976302080/diff/5629499534213120/test/tests/typedObjects.js File test/tests/typedObjects.js (right): http://codereview.adblockplus.org/5728072976302080/diff/5629499534213120/test/tests/typedObjects.js#newcode679 test/tests/typedObjects.js:679: for (let array of [array1, array2, array3, array4]) This ...
5 years, 4 months ago (2014-05-16 13:23:14 UTC) #2
Wladimir Palant
http://codereview.adblockplus.org/5728072976302080/diff/5629499534213120/lib/typedObjects/arrayTypes.js File lib/typedObjects/arrayTypes.js (right): http://codereview.adblockplus.org/5728072976302080/diff/5629499534213120/lib/typedObjects/arrayTypes.js#newcode168 lib/typedObjects/arrayTypes.js:168: let dst = Uint8Array(buffers[bufferIndex], byteOffset, copyBytes); Chrome and Safari ...
5 years, 4 months ago (2014-05-19 07:58:34 UTC) #3
René Jeschke
This LGTM, but there are two naming issues (which are both not really a must-fix): ...
5 years, 4 months ago (2014-05-20 16:58:51 UTC) #4
Felix Dahlke
On 2014/05/20 16:58:51, René Jeschke wrote: > This LGTM, but there are two naming issues ...
5 years, 4 months ago (2014-05-21 07:21:17 UTC) #5
Wladimir Palant
On 2014/05/21 07:21:17, Felix H. Dahlke wrote: > But I don't really like the term ...
5 years, 4 months ago (2014-05-21 07:27:54 UTC) #6
Wladimir Palant
I renamed cleanupValue into initialValue. The new patchset also fixes a few other minor issues. ...
5 years, 2 months ago (2014-07-11 07:28:53 UTC) #7
René Jeschke
5 years, 2 months ago (2014-07-11 07:33:34 UTC) #8
On 2014/07/11 07:28:53, Wladimir Palant wrote:
> I renamed cleanupValue into initialValue. The new patchset also fixes a few
> other minor issues. The watchers are still called like that given that Mozilla
> uses this terminology and nobody can suggest a better term.

Fair enough. Checked the fixes. 
LGTM
Sign in to reply to this message.

Powered by Google App Engine
RSS Feeds Recent Issues | This issue
This is Rietveld 87257f5