Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code

Issue 29331590: Issue #1484 - Make PassthroughAPP a pass-through again (Closed)

Created:
Nov. 30, 2015, 12:36 p.m. by Eric
Modified:
Dec. 22, 2015, 2:39 p.m.
Reviewers:
sergei, Oleksandr
CC:
Felix Dahlke
Visibility:
Public.

Description

Issue #1484 - Make PassthroughAPP a pass-through again Create new class 'WbPassthroughSinkStartPolicy', deriving from the template instantiation of 'CustomSinkStartPolicy' that was previously used. Shadow its 'OnStart' member function with one that replicates previous behavior. Extract code that was previously added to 'CustomSinkStartPolicy::OnStart()' into 'WbPassthroughSinkStartPolicy::OnStart'. Restore 'const' declaration to 'CustomSinkStartPolicy::OnStart'. Rename 'WBPassthru' to 'WbPassthroughPolicy' to reflect the template argument name 'Policy' in PassthroughAPP that it instantiates.

Patch Set 1 : #

Total comments: 5

Patch Set 2 : rebase only #

Patch Set 3 : #

Unified diffs Side-by-side diffs Delta from patch set Stats (+633 lines, -611 lines) Patch
M src/plugin/PluginMimeFilterClient.cpp View 1 chunk +0 lines, -4 lines 0 comments Download
M src/plugin/PluginWbPassThrough.h View 1 2 2 chunks +37 lines, -15 lines 0 comments Download
M src/plugin/PluginWbPassThrough.cpp View 1 3 chunks +17 lines, -6 lines 0 comments Download
M src/plugin/passthroughapp/SinkPolicy.h View 1 1 chunk +169 lines, -169 lines 0 comments Download
M src/plugin/passthroughapp/SinkPolicy.inl View 1 1 chunk +410 lines, -417 lines 0 comments Download

Messages

Total messages: 7
Eric
The second of two reviews to fix #1484. This one is rather more subtle than ...
Nov. 30, 2015, 1:59 p.m. (2015-11-30 13:59:49 UTC) #1
Eric
Ping. It's been more than two weeks since I posted this review and it's received ...
Dec. 15, 2015, 2:16 p.m. (2015-12-15 14:16:29 UTC) #2
Oleksandr
Test cases for these changes would be to check if you ever experience the "Navigation ...
Dec. 16, 2015, 1:33 p.m. (2015-12-16 13:33:31 UTC) #3
Eric
@sergei. It's now been three weeks with no response from you at all on this. ...
Dec. 22, 2015, 12:54 p.m. (2015-12-22 12:54:48 UTC) #4
sergei
LGTM https://codereview.adblockplus.org/29331590/diff/29331602/src/plugin/PluginWbPassThrough.h File src/plugin/PluginWbPassThrough.h (right): https://codereview.adblockplus.org/29331590/diff/29331602/src/plugin/PluginWbPassThrough.h#newcode92 src/plugin/PluginWbPassThrough.h:92: typedef PassthroughAPP::CustomSinkStartPolicy<WbPassthroughProtocol, WBPassthruSink> BaseClass; I would use __super ...
Dec. 22, 2015, 2:04 p.m. (2015-12-22 14:04:40 UTC) #5
Eric
https://codereview.adblockplus.org/29331590/diff/29331602/src/plugin/PluginWbPassThrough.h File src/plugin/PluginWbPassThrough.h (right): https://codereview.adblockplus.org/29331590/diff/29331602/src/plugin/PluginWbPassThrough.h#newcode95 src/plugin/PluginWbPassThrough.h:95: IInternetProtocolSink *pOIProtSink, IInternetBindInfo *pOIBindInfo, On 2015/12/22 14:04:40, sergei wrote: ...
Dec. 22, 2015, 2:34 p.m. (2015-12-22 14:34:31 UTC) #6
sergei
Dec. 22, 2015, 2:39 p.m. (2015-12-22 14:39:37 UTC) #7
Message was sent while issue was closed.
LGTM

https://codereview.adblockplus.org/29331590/diff/29331602/src/plugin/PluginWb...
File src/plugin/PluginWbPassThrough.h (right):

https://codereview.adblockplus.org/29331590/diff/29331602/src/plugin/PluginWb...
src/plugin/PluginWbPassThrough.h:95: IInternetProtocolSink *pOIProtSink,
IInternetBindInfo *pOIBindInfo,
On 2015/12/22 14:34:31, Eric wrote:
> On 2015/12/22 14:04:40, sergei wrote:
> > Just noticed that we are using '*' and ' ' slightly differently
> 
> I changed them all. Patch set 2 is rebase only. Patch set three makes all the
> '*' types consistent.

It's also the same in cpp file, but for me it's not critical, especially it
might be better to be in another no-issue commit.

Powered by Google App Engine
This is Rietveld