Rietveld Code Review Tool
Help | Bug tracker | Discussion group | Source code

Issue 6215938672164864: [IE] Replace ATL::CRect (Closed)

Created:
June 25, 2014, 7:02 p.m. by Eric
Modified:
July 24, 2014, 12:34 p.m.
Visibility:
Public.

Description

Replace ATL::CRect with a local rectangle class. All the code was using were functions for height and width.

Patch Set 1 #

Total comments: 10

Patch Set 2 : Comments addressed; Rebased #

Total comments: 2

Patch Set 3 : hopefully final #

Total comments: 1
Unified diffs Side-by-side diffs Delta from patch set Stats (+30 lines, -6 lines) Patch
M src/plugin/PluginClass.cpp View 1 2 6 chunks +30 lines, -6 lines 1 comment Download

Messages

Total messages: 14
Eric
June 25, 2014, 7:04 p.m. (2014-06-25 19:04:46 UTC) #1
Oleksandr
LGTM
July 9, 2014, 7:26 p.m. (2014-07-09 19:26:16 UTC) #2
Oleksandr
http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp File src/plugin/PluginClass.cpp (right): http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp#newcode59 src/plugin/PluginClass.cpp:59: namespace { Nit: New line before { http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp#newcode61 src/plugin/PluginClass.cpp:61: ...
July 9, 2014, 7:29 p.m. (2014-07-09 19:29:08 UTC) #3
Felix Dahlke
http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp File src/plugin/PluginClass.cpp (right): http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp#newcode60 src/plugin/PluginClass.cpp:60: // Without an extra namespace within the anonymous one, ...
July 10, 2014, 4:49 a.m. (2014-07-10 04:49:02 UTC) #4
Oleksandr
http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp File src/plugin/PluginClass.cpp (right): http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp#newcode85 src/plugin/PluginClass.cpp:85: // CPluginClass Visually I think it makes sense, and ...
July 14, 2014, 7:56 a.m. (2014-07-14 07:56:20 UTC) #5
Eric
http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp File src/plugin/PluginClass.cpp (right): http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp#newcode60 src/plugin/PluginClass.cpp:60: // Without an extra namespace within the anonymous one, ...
July 23, 2014, 11:25 a.m. (2014-07-23 11:25:05 UTC) #6
Eric
Removed patches for ATL_Deprecate.h, which isn't in the public tree yet. http://codereview.adblockplus.org/6215938672164864/diff/5629499534213120/src/plugin/PluginClass.cpp File src/plugin/PluginClass.cpp (right): ...
July 23, 2014, 12:03 p.m. (2014-07-23 12:03:18 UTC) #7
Eric
Added Sergei
July 23, 2014, 12:03 p.m. (2014-07-23 12:03:53 UTC) #8
sergei
LGTM, beside `Local` and the comment below. > The trouble with that policy is that ...
July 23, 2014, 1:34 p.m. (2014-07-23 13:34:48 UTC) #9
Eric
Removed noexcept comments. Removed extraneous anonymous namespace. > If we really want it, I would ...
July 23, 2014, 4:34 p.m. (2014-07-23 16:34:14 UTC) #10
Wladimir Palant
LGTM
July 24, 2014, 6:50 a.m. (2014-07-24 06:50:57 UTC) #11
Felix Dahlke
http://codereview.adblockplus.org/6215938672164864/diff/5634387206995968/src/plugin/PluginClass.cpp File src/plugin/PluginClass.cpp (right): http://codereview.adblockplus.org/6215938672164864/diff/5634387206995968/src/plugin/PluginClass.cpp#newcode56 src/plugin/PluginClass.cpp:56: namespace AdblockPlus This would normally be an anonymous namespace, ...
July 24, 2014, 7:24 a.m. (2014-07-24 07:24:17 UTC) #12
Eric
On 2014/07/24 07:24:17, Felix H. Dahlke wrote: > I still think the most > pragmatic ...
July 24, 2014, 11:35 a.m. (2014-07-24 11:35:45 UTC) #13
Felix Dahlke
July 24, 2014, 12:03 p.m. (2014-07-24 12:03:21 UTC) #14
On 2014/07/24 11:35:45, Eric wrote:
> On 2014/07/24 07:24:17, Felix H. Dahlke wrote:
> > I still think the most
> > pragmatic way would be to just give the class a name that won't clash with
> > globals, i.e. "Rect".
> 
> Is this a blocker for a commit, or not?
> 
> The original class, ATL::CRect, is a rather complete library-quality class. If
> we ever need such a thing, this class would belong in such a library, our own
or
> someone else's. I see no issue using an existing library namespace,
particularly
> one that's unlikely to need classes for screen rendering.
> 
> And I really dislike 'Rect', since the base class is 'RECT', a Windows system
> class, which differs only in capitalization.

True, neither way is really clean. LGTM.

Powered by Google App Engine
This is Rietveld